• Informatique: Rappel sur les MCD et les MCT

     

    RAPPELS DE COURS SUR LES MCD ET LES MCT

     

    I - LE MCD

    1) Modèle relationnel

    Nom relation (clé primaire, attributs, #clé étrangère)

    2) Requêtes

    R1=sélection(entité/propriété="")
    R2=jointure(R1,entité ou association/identifiant)
    R3=projection(R2/prop1,...,propN)

    Exemple : sélection(UV/libellé UV=sociologie)
     

    3) Algorithmes

    Différentes structures :

    - Si / alors / sinon / Fin si

    - Tant que / actions / Fin tant que

    - Répéter / actions / Jusqu'à 

    Exemple 1 :
    Début
         Saisir x, y, z
         si x>y
              alors ""<- ""
              sinon ""<- ""
         fin si
         si x>z
              alors ""<- ""
              sinon ""<- ""
         fin si
         afficher
    Fin

    Exemple 2 :
    Début
         Choi<- ""
         Tant que Choi<- ""
         Afficher ""
         Saisir Choi
         Fin tant que
    Fin
     


    II - LE MCT
    Schéma :

                        (Evenement)
                        

                         |Opération|
                         |        |      |

                     (Rt1)        (Rt2)

    Exemple : fin semaine

                    saisie factures

                    fac saisies

    OUTGDA Mektar

    « Informatique: methodes MPM et PERTLe bilan fonctionel »

  • Commentaires

    Aucun commentaire pour le moment

    Suivre le flux RSS des commentaires


    Ajouter un commentaire

    Nom / Pseudo :

    E-mail (facultatif) :

    Site Web (facultatif) :

    Commentaire :